4.0

Install

Kafka Compatibility 

  • Kafka 2.5+ (Confluent 5.5) - Stream reactor 2.0.0+
  • Kafka 2.0 -> 2.4 (Confluent 5.4) - Stream reactor 1.2.7

Installing 

For the entire collection, unpack the archive under /opt or your preferred location:

wget https://github.com/lensesio/stream-reactor/releases/download/x.x.x/stream-reactor-x.x.x-x.x.x.tar.gz
tar xvf stream-reactor-x.x.x-x.x.x.tar.gz -C /opt

Within the unpacked directory you will find the following structure:


/opt/stream-reactor-x.x.x-x.x.x
├── bin
├── conf
├── libs
├── LICENSE
└── README.md

The libs directory contains all the Stream Reactor Connector jars. Edit your Connect worker properties add the path to the directory containing the connectors and restart your workers. Repeat this process for all the Connect workers in your cluster. The connectors must be available to all the workers.

Example:

plugin.path=/usr/share/connectors,/opt/stream-reactor-x.x.x-x.x.x/libs

Dockers and Kubernetes 

Please see the Connector user guide section